Обновление компонента Docman

docmanСегодня неожиданно узнала, что компонент Docman на моем сайте вдруг перестал работать. Когда это случилось, я не знаю. После миграции с одной версии на другую я проверила работоспособность, все было в порядке.
Возможно, он сломался при переносе сайта на другой хостинг.

Но в любом случае та, устаревшая версия компонента, не была предназначена для Joomla 1.5.

Компонент перестал «видеть» файлы, которые находились там, где им и положено быть: в директории dmdocuments/. Нужно было срочно восстановить работоспособность компонента, мой пользователь очень хотел скачать файл с моего сайта.

Нашла новую версию для полуторной Джумлы, самую последнюю искать было некогда, скачала первую попавшуюся. Обновить смогу как-нибудь попозже, не торопясь.

В ветке форума нашла версию docman_v1.5.1.stable. Там же написано, как нужно обновиться:
Удалить папку com_docman из папки ./administrator/components/
Удалить папку com_docman из папки ./components/

А дальше устанавливаем компонент, как и все прочие через Расширения — Установка/Удаление. Да, пришлось поменять один зазипованный файл, который почему-то оказался битым. Когда он смог побиться? Закачав файл на сайт, я всегда проверяю, все ли в порядке. Все и было в порядке. Тем не менеее поменяла файл, все работает.

Вот и все. Нужно будет обновить компонент до последней версии. Но не сейчас, сейчас утро воскресенья и у меня запланировано много домашних дел.

Ваш отзыв

XHTML: Вы можете использовать следующие теги: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>